Long poll returned error in Silverlight application in IE

Apr 28, 2011 at 3:41 PM

I'm using laharsub in a silverlight app and while I successfully receive messages, after a short amount of time in IE I get:

{System.InvalidOperationException: HTTP long poll returned an error. Subscription is terminated. ---> System.Net.WebException: The remote server returned an error: NotFound. ---> System.Net.WebException: The remote server returned an error: NotFound.
   at System.Net.Browser.BrowserHttpWebRequest.InternalEndGetResponse(IAsyncResult asyncResult)
   at System.Net.Browser.BrowserHttpWebRequest.<>c__DisplayClass5.<EndGetResponse>b__4(Object sendState)
   at System.Net.Browser.AsyncHelper.<>c__DisplayClass4.<BeginOnUI>b__1(Object sendState)
   --- End of inner exception stack trace ---
   at System.Net.Browser.AsyncHelper.BeginOnUI(SendOrPostCallback beginMethod, Object state)
   at System.Net.Browser.BrowserHttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at Laharsub.Client.HttpLongPollManager.ProcessPollResponse(IAsyncResult result, PollContext context)
   at Laharsub.Client.HttpLongPollManager.ProcessNext(IAsyncResult result)
   --- End of inner exception stack trace ---}

The server is running as a console and shows no errors. My publish app is a console app, receiving events from a .NET component and pushing data out based upon them (no subscriptions in it); again there are no errors in this. The client is Silverlight.

I haven't tried debugging into this yet; thought I'd post here first before investigating, just to see if it's a known issue. Note that this appears to be an IE issue; the messages still get pushed through to a FF client.